summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 14 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index fe2bb00..3d04abf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,29 +3,29 @@
# $Id$
-# This file is part of libao-polyp.
+# This file is part of libao-pulse.
#
-# libao-polyp is free software; you can redistribute it and/or modify it
+# libao-pulse is free software; you can redistribute it and/or modify it
# under the terms of the GNU General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
-# libao-polyp is distributed in the hope that it will be useful, but
+# libao-pulse is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU General Public License
-# along with libao-polyp; if not, write to the Free Software Foundation,
+# along with libao-pulse; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
AC_PREREQ(2.57)
-AC_INIT([libao-polyp],[0.9.0],[mzyvonbcbylc (at) 0pointer (dot) de])
-AC_CONFIG_SRCDIR([src/ao_polyp.c])
+AC_INIT([libao-pulse],[0.9.0],[mzyvonbcbylc (at) 0pointer (dot) de])
+AC_CONFIG_SRCDIR([src/ao_pulse.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign 1.9 -Wall])
-AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/libao-polyp/])
+AC_SUBST(PACKAGE_URL, [http://0pointer.de/lennart/projects/libao-pulse/])
if type -p stow > /dev/null && test -d /usr/local/stow ; then
AC_MSG_NOTICE([*** Found /usr/local/stow: default install prefix set to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
@@ -46,16 +46,16 @@ AC_FUNC_MALLOC
PKG_PROG_PKG_CONFIG
-if test -d ../polypaudio ; then
- POLYP_CFLAGS='-I$(top_srcdir)/../polypaudio/src'
- POLYP_LIBS='-L$(top_srcdir)/../polypaudio/src/.libs -lpolyp-simple'
- echo "*** Found polypaudio in ../polypaudio, using that version ***"
+if test -d ../pulseaudio ; then
+ PULSE_CFLAGS='-I$(top_srcdir)/../pulseaudio/src'
+ PULSE_LIBS='-L$(top_srcdir)/../pulseaudio/src/.libs -lpulse-simple'
+ echo "*** Found pulseaudio in ../pulseaudio, using that version ***"
else
- PKG_CHECK_MODULES(POLYP, [ polyplib-simple >= 0.9.0 ])
+ PKG_CHECK_MODULES(PULSE, [ libpulse-simple >= 0.9.0 ])
fi
-AC_SUBST(POLYP_LIBS)
-AC_SUBST(POLYP_CFLAGS)
+AC_SUBST(PULSE_LIBS)
+AC_SUBST(PULSE_CFLAGS)
PKG_CHECK_MODULES(LIBAO, [ ao >= 0.8.5 ])
LIBAO_MODDIR=`pkg-config --variable=libdir ao`/ao/plugins-2