summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..80795ce
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,27 @@
+# $Id$
+#
+# This file is part of libao-polyp.
+#
+# libao-polyp is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libao-polyp is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with libao-polyp; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+aolibdir=$(libdir)/ao/plugins-2
+
+aolib_LTLIBRARIES=libpolyp.la
+
+libpolyp_la_SOURCES=ao_polyp.c
+libpolyp_la_LDFLAGS=-module -avoid-version
+libpolyp_la_LIBADD=$(AM_LIBADD) $(POLYP_LIBS)
+libpolyp_la_CFLAGS=$(AM_CFLAGS) $(POLYP_CLAGS)