summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-01-07 17:25:25 +0000
committerLennart Poettering <lennart@poettering.net>2005-01-07 17:25:25 +0000
commit966b81addf7e728bd62ed86246741d30926351c2 (patch)
tree7d3667c8eaa35369d26aec9af003a24d7011c5e2 /Makefile.am
parentbba080b1fdec6efdcc7144d8236d8f65a9c7bc06 (diff)
rename libaar to libasyncns
git-svn-id: file:///home/lennart/svn/public/libasyncns/trunk@4 cc0fb855-19ed-0310-866e-8c1d96e4abae
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..38619aa
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,58 @@
+# $Id$
+#
+# This file is part of libasyncns.
+#
+# libasyncns is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libasyncns is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with libasyncns; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+EXTRA_DIST = bootstrap.sh README LICENSE doxygen/Makefile.am doxygen/Makefile.in doxygen/doxygen.conf.in libtool.m4 ltdl.m4
+SUBDIRS=polyp doc libltdl
+
+MAINTAINERCLEANFILES=README
+noinst_DATA = README
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = polyplib.pc polyplib-simple.pc polyplib-error.pc polyplib-mainloop.pc polyplib-browse.pc
+
+if HAVE_GLIB20
+pkgconfig_DATA += \
+ polyplib-glib-mainloop.pc
+endif
+
+if HAVE_GLIB12
+pkgconfig_DATA += \
+ polyplib-glib12-mainloop.pc
+endif
+
+README:
+ rm -f README
+ $(MAKE) -C doc README
+ cd $(srcdir) && ln -s doc/README README
+
+homepage: all dist doxygen
+ test -d $$HOME/homepage/private
+ mkdir -p $$HOME/homepage/private/projects/libasyncns $$HOME/homepage/private/projects/libasyncns/doxygen
+ cp libasyncns-@PACKAGE_VERSION@.tar.gz $$HOME/homepage/private/projects/libasyncns
+ cp doc/README.html doc/FAQ.html doc/cli.html doc/daemon.html doc/modules.html doc/style.css $$HOME/homepage/private/projects/libasyncns
+ cp -a doxygen/html/* $$HOME/homepage/private/projects/libasyncns/doxygen
+ cp $$HOME/homepage/private/projects/libasyncns/README.html $$HOME/homepage/private/projects/libasyncns/index.html
+
+distcleancheck:
+ @:
+
+doxygen:
+ $(MAKE) -C doxygen
+
+.PHONY: homepage distcleancheck doxygen