summaryrefslogtreecommitdiffstats
path: root/doxygen/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-01-07 20:34:53 +0000
committerLennart Poettering <lennart@poettering.net>2005-01-07 20:34:53 +0000
commit6e7b4e60d5cbbc34b99b6a4cb3e22d061e1843a7 (patch)
treeac8fc89d5be15ab8cbf7f88874c48132a0ae4035 /doxygen/Makefile.am
parent4c4420d73c00d8f50fdc54c8e68977d9e2d59742 (diff)
* add documentation
* add SVN ids * add doxygen stuff * gcc 2.95 compat * add LICENSE * complete autoconf/autotools setup * cleanup example * fix asyncns_wait() * cope with prctl() failing git-svn-id: file:///home/lennart/svn/public/libasyncns/trunk@10 cc0fb855-19ed-0310-866e-8c1d96e4abae
Diffstat (limited to 'doxygen/Makefile.am')
-rw-r--r--doxygen/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/doxygen/Makefile.am b/doxygen/Makefile.am
new file mode 100644
index 0000000..79ba835
--- /dev/null
+++ b/doxygen/Makefile.am
@@ -0,0 +1,26 @@
+# $Id$
+#
+# This file is part of libasyncns.
+#
+# libasyncns is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# libasyncns is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public License
+# along with libasyncns; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+doxygen: doxygen.conf
+ doxygen $<
+
+clean-local:
+ rm -rf html
+
+.PHONY: all doxygen