summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5e0a68c..ea13552 100644
--- a/configure.ac
+++ b/configure.ac
@@ -65,6 +65,13 @@ AC_CHECK_FUNCS([memset select strndup setresuid setreuid])
AC_CHECK_LIB(nsl, gethostbyname)
AC_CHECK_LIB(socket, connect)
+AC_CHECK_FUNC(res_query, ,
+ [AC_CHECK_LIB(resolv, res_query, [],
+ [ AC_CHECK_LIB(bind, res_query,
+ [], [ AC_MSG_ERROR(res_query not found) ] ) ] )
+ ]
+)
+
ACX_PTHREAD
# If using GCC specify some additional parameters