summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMatthias Clasen <mclasen@redhat.com>2008-09-26 00:52:00 +0200
committerLennart Poettering <lennart@poettering.net>2008-09-26 00:54:12 +0200
commit6c0ffa3f480ff1d97d897128545c275f167263e8 (patch)
tree097a992e19fdc94bfc4715cf85e08058d3d0c8ee /Makefile.am
parentf855a098f537fd8d4cb381f07ea5badc9646515c (diff)
Enable canberra-gtk-module via GConf
The most recent version of gnome-settings-daemon now supports activating Gtk+ modules via a GConf setting. We should be using this to activate our Gtk+ module automatically on install. Signed-off-by: Lennart Poettering <lennart@poettering.net>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c01de2..27c382d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,6 +31,20 @@ if HAVE_GTK
pkgconfig_DATA += libcanberra-gtk.pc
endif
+schemasdir = $(GCONF_SCHEMA_FILE_DIR)
+schemas_DATA = libcanberra.schemas
+
+if GCONF_SCHEMAS_INSTALL
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schemas_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_builddir)/data/$$p ; \
+ done \
+ fi
+else
+install-data-local:
+endif
+
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
ACLOCAL_AMFLAGS = -I m4