summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-05-26 20:29:09 +0200
committerLennart Poettering <lennart@poettering.net>2009-05-26 20:29:09 +0200
commit2eede08188f626d42c1bba3a3726fc7c5e44c3e9 (patch)
treecf4fe0f03e7da63e3d4d96d2b591f93101f1090f /configure.ac
parentd6f5d1e3ffe06b88ded60b2a733909955a1caf9c (diff)
build-system: introduce macros PA_MAJOR, PA_MINOR, PA_CHECK_VERSION
This is mostly based on Christian Persch's work but moves the version macros into the main header file. https://bugs.freedesktop.org/show_bug.cgi?id=21655
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f0abff5..398a2e9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -19,9 +19,13 @@
# License along with libcanberra. If not, see
# <http://www.gnu.org/licenses/>.
+m4_define([ca_major],[0])
+m4_define([ca_minor],[13])
+m4_define([ca_version],[ca_major.ca_minor])
+
AC_PREREQ(2.63)
-AC_INIT([libcanberra],[0.12],[mzyvopnaoreen (at) 0pointer (dot) de])
+AC_INIT([libcanberra],[ca_version],[mzyvopnaoreen (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([src/common.c])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR(m4)
@@ -564,6 +568,9 @@ AM_CONDITIONAL([BUILTIN_OSS], [test "x$BUILTIN_OSS" = x1])
AM_CONDITIONAL([BUILTIN_GSTREAMER], [test "x$BUILTIN_GSTREAMER" = x1])
AM_CONDITIONAL([BUILTIN_NULL], [test "x$BUILTIN_NULL" = x1])
+AC_SUBST([CA_MAJOR],[ca_major])
+AC_SUBST([CA_MINOR],[ca_minor])
+
GTK_DOC_CHECK(1.9)
###################################
@@ -575,6 +582,7 @@ Makefile
src/Makefile
libcanberra.pc
libcanberra-gtk.pc
+src/canberra.h
gtkdoc/Makefile
doc/Makefile
doc/README.html