summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2011-02-09 22:35:00 +0100
committerLennart Poettering <lennart@poettering.net>2011-02-09 22:35:00 +0100
commit786b4b05dc1bfc725995f4c2556d49aec5e2ae1b (patch)
tree434e8f6e016cf8e0e20645db8d62b3bc9b070fc1 /configure.ac
parentdfd5e05f01dd4d28bc6c5ebc3c991404723bc076 (diff)
systemd: add unit for bootup and shutdown sounds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4d1376c..a6966da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -502,6 +502,18 @@ if test "x${HAVE_CACHE}" = x1 ; then
AC_DEFINE([HAVE_CACHE], 1, [Do cacheing?])
fi
+#
+# systemd
+#
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [],
+ [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+if test "x$with_systemdsystemunitdir" != xno; then
+ AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+fi
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir" -a "x$with_systemdsystemunitdir" != xno ])
+
### LYNX documentation generation ###
AC_ARG_ENABLE([lynx],
@@ -769,6 +781,7 @@ echo "
Enable GTK3+: ${ENABLE_GTK3}
GTK3 Modules Directory: ${GTK3_MODULES_DIR}
Enable udev: ${ENABLE_UDEV}
+ systemd Unit Directory: ${with_systemdsystemunitdir}
"