summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-08-14 17:45:29 +0200
committerLennart Poettering <lennart@poettering.net>2008-08-14 17:45:29 +0200
commit53335cee493865e062e8e51b1f81c84882895038 (patch)
tree45ee280140934835ee711a24c262f2f8d53b08db /doc/Makefile.am
parent17654c7076360fc7633f491fb3ef9e950f2286b2 (diff)
add proper documentation
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..819a6f9
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,35 @@
+# This file is part of libcanberra.
+#
+# Copyright 2008 Lennart Poettering
+#
+# libcanberra is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation, either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# libcanberra is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with libcanberra. If not, see
+# <http://www.gnu.org/licenses/>.
+
+noinst_DATA = README.html README
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in
+
+MAINTAINERCLEANFILES = README.html
+CLEANFILES =
+
+if USE_LYNX
+README: README.html
+ lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
+
+CLEANFILES += README
+endif
+
+tidy: README.html
+ tidy -qe < README.html ; true
+
+.PHONY: tidy