summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 3c01de2..27c382d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -31,6 +31,20 @@ if HAVE_GTK
pkgconfig_DATA += libcanberra-gtk.pc
endif
+schemasdir = $(GCONF_SCHEMA_FILE_DIR)
+schemas_DATA = libcanberra.schemas
+
+if GCONF_SCHEMAS_INSTALL
+install-data-local:
+ if test -z "$(DESTDIR)" ; then \
+ for p in $(schemas_DATA) ; do \
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(top_builddir)/data/$$p ; \
+ done \
+ fi
+else
+install-data-local:
+endif
+
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
ACLOCAL_AMFLAGS = -I m4