summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2edc828..0026d7f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,7 +16,7 @@
# Lesser General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public
-# License along with libcanberra. If not, If not, see
+# License along with libcanberra. If not, see
# <http://www.gnu.org/licenses/>.
AC_PREREQ(2.62)
@@ -84,6 +84,8 @@ esac
AM_CONDITIONAL(OS_IS_WIN32, test "x$os_is_win32" = "x1")
+AM_CONDITIONAL(USE_VERSION_SCRIPT, test "x$supports_anon_versioning" = "xyes" )
+
###################################
# Basic environment checks #
###################################
@@ -272,7 +274,7 @@ AC_ARG_ENABLE([gtk],
[gtk=auto])
if test "x${gtk}" != xno ; then
- PKG_CHECK_MODULES(GTK, [ gtk+-2.0 gthread-2.0 ],
+ PKG_CHECK_MODULES(GTK, [ gtk+-2.0 >= 2.14 gthread-2.0 ],
[
HAVE_GTK=1
AC_DEFINE([HAVE_GTK], 1, [Have GTK?])