summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e40ec1f..aee25af 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -24,6 +24,8 @@ gnomeshutdowndir = $(datadir)/gnome/shutdown
gnomeautostartdir = $(datadir)/gnome/autostart
+gdmautostartdir = $(datadir)/gdm/autostart/LoginWindow/
+
AM_CFLAGS = $(PTHREAD_CFLAGS) -DCA_PLUGIN_PATH=\"$(plugindir)\"
AM_CXXFLAGS = $(PTHREAD_CFLAGS)
AM_LDADD = $(PTHREAD_LIBS)
@@ -321,6 +323,9 @@ EXTRA_DIST += \
gnomeautostart_DATA = \
libcanberra-login-sound.desktop
+gdmautostart_DATA = \
+ libcanberra-ready-sound.desktop
+
gnomeshutdown_SCRIPTS = \
libcanberra-logout-sound.sh
@@ -335,6 +340,9 @@ libcanberra-logout-sound.sh: libcanberra-logout-sound.sh.in Makefile
libcanberra-login-sound.desktop: libcanberra-login-sound.desktop.in Makefile
sed -e 's,@bindir\@,$(bindir),g' < $< > $@
+libcanberra-ready-sound.desktop: libcanberra-ready-sound.desktop.in Makefile
+ sed -e 's,@bindir\@,$(bindir),g' < $< > $@
+
endif
test_canberra_SOURCES = \