summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 48c75ba..d6a5352 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -274,6 +274,7 @@ endif
endif
bin_PROGRAMS =
+CLEANFILES =
if HAVE_UDEV
if HAVE_ALSA
@@ -291,6 +292,25 @@ canberra_boot_LDADD = \
canberra_boot_CFLAGS = \
$(UDEV_CFLAGS)
+if HAVE_SYSTEMD
+
+systemdsystemunit_DATA = \
+ canberra-system-bootup.service \
+ canberra-system-shutdown.service \
+ canberra-system-shutdown-reboot.service
+
+EXTRA_DIST += \
+ canberra-system-bootup.service.in \
+ canberra-system-shutdown.service.in \
+ canberra-system-shutdown-reboot.service.in
+
+%.service: %.service.in
+ $(AM_V_GEN)sed -e 's,@bindir\@,$(bindir),g' $< > $@
+
+CLEANFILES += \
+ $(systemdsystemunit_DATA)
+
+endif
endif
endif
@@ -415,7 +435,7 @@ gdmautostart_DATA = \
gnomeshutdown_SCRIPTS = \
libcanberra-logout-sound.sh
-CLEANFILES = \
+CLEANFILES += \
libcanberra-login-sound.desktop \
libcanberra-ready-sound.desktop \
libcanberra-logout-sound.sh