summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b6b57ea..ad13181 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -40,7 +40,7 @@ libsydney_la_SOURCES = \
bbuffer.c bbuffer.h \
format.c fomat.h \
volscale.c volscale.h \
- byteswap.c byteswap.h \
+ bswap.c bswap.h \
continued-fraction.c continued-fraction.h \
zero.c zero.h \
add.c add.h \
@@ -49,9 +49,8 @@ libsydney_la_SOURCES = \
interleave.c interleave.h \
converter.c converter.h \
g711.c g711.h \
- mutex.c mutex.h \
- once.c once.h \
- thread.c thread.h \
+ mutex-posix.c mutex.h \
+ thread-posix.c thread.h \
bufferq.c buffer.h \
meta-name-table.h
# asyncq.c asyncq.h
@@ -97,7 +96,7 @@ BUILT_SOURCES = \
meta-name-table.h
meta-name-table.h: meta-name-table.gperf Makefile
- gperf -t -N sa_lookup_meta_name -H sa_hash_meta_name -p -C < $< | sed -e 's/{""}/{"", 0}/g' > $@
+ gperf -L ANSI-C -t -N sa_lookup_meta_name -H sa_hash_meta_name -p -C < $< | sed -e 's/{""}/{"", 0}/g' > $@
fixme:
find -name '*.c' -exec fgrep -H -A 3 -B 3 -i FIXME \{\} \;