summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-03-03 01:25:46 +0000
committerLennart Poettering <lennart@poettering.net>2004-03-03 01:25:46 +0000
commit285f7ad7d0aed48cd5cb13a2437e80d26fffc254 (patch)
tree09dddce764a851f970cdaffd40abee0f6bd84dc0 /src/Makefile.am
parent6f8db736a197520f88aab498eead8599641b10fe (diff)
commit initial release
git-svn-id: file:///home/lennart/svn/public/pgets/trunk@3 768266df-afd4-0310-94a7-d396c829e022
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..ea26863
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,47 @@
+# $Id$
+
+# This file is part of pgets.
+#
+# pgets is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# pgets is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with pgets; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+sbin_PROGRAMS =
+
+if SQLITE
+sbin_PROGRAMS += pgets-sqlite
+endif
+
+if POSTGRES
+sbin_PROGRAMS += pgets-postgres
+endif
+
+
+SOURCES = pgets.c pgets.h \
+ modem.c modem.h \
+ lock.c lock.h \
+ util.c util.h \
+ db.h
+
+pgets_sqlite_SOURCES = $(SOURCES) sqlite.c
+pgets_sqlite_LDADD = $(LDADD) $(SQLITE_LIBS)
+pgets_sqlite_CLFAGS = $(AM_CFLAGS) $(SQLITE_CFLAGS)
+
+pgets_postgres_SOURCES = $(SOURCES) postgres.c
+pgets_postgres_LDADD = $(LDADD) $(POSTGRES_LIBS)
+pgets_postgres_CLFAGS = $(AM_CFLAGS) $(POSTGRES_CFLAGS)
+
+svnkeywords:
+ svn propset svn:keywords Id *.c *.h Makefile.am
+
+.PHONY: svnkeywords