summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorColin Guthrie <cguthrie@mandriva.org>2010-12-04 13:47:43 +0000
committerColin Guthrie <cguthrie@mandriva.org>2010-12-05 15:59:13 +0000
commit36f7a408298efd1e3a47a4d62742b5134b80cee9 (patch)
treeb69960684cb7216e037f381edcbee239cc9cd845 /Makefile.am
parent2f67d6b65154e8bb3f4463a9c4c551a6cdae2d46 (diff)
build-sys: Include the .version file in the distribution tarball
As per the comments in git-version-gen, the .version file that is typically generated automatically during build should be included in the tarball, so generate it in the dist-hook. This fixes a problem when running make distcheck which uses a read-only source folder and thus cannot generate the $top_srcdir/.version as part of it's build process (it uses a _build folder which is r/w) and thus cannot be built.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b8e22eae..a8a9eaac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -77,6 +77,7 @@ dist-hook:
( git-changelog.perl || echo "git-changelog.perl failed." ) > ${distdir}/ChangeLog 2>&1 ; \
fi
echo $(VERSION) > $(distdir)/.tarball-version
+ echo $(VERSION) > $(distdir)/.version
.PHONY: homepage distcleancheck doxygen