summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@gmail.com>2009-01-08 12:29:09 +0200
committerMarc-André Lureau <marcandre.lureau@gmail.com>2009-01-08 15:12:25 +0200
commitdb193f17200d63bfe59bc3a9196f15d5d59efaee (patch)
treede2d57865dd1a41f0111cc4c4ada231a89912d25 /Makefile.am
parenta206ac0fb58d757da30897ca9a64ae642d1865d1 (diff)
build: introduce $SKIP_GIT for make dist (off-line or behind a proxy).
There might be a better way doing that, but 'alias git=echo' is not a solution, :(
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index bc46cac4..f4dd9989 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,7 +56,7 @@ fedora-snapshot: dist
dist-hook:
if test -d .git ; then \
- git pull ; \
+ test -z $$SKIP_GIT && git pull ; \
chmod u+w ${distdir}/ChangeLog || true ; \
( git-changelog.perl || echo "git-changelog.perl failed." ) > ${distdir}/ChangeLog 2>&1 ; \
fi