summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2010-09-13 18:41:30 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2010-09-23 17:17:03 +0530
commit83d3c8f22bab997dde81074fd547aef6e56451d5 (patch)
treebf378a032142ff0cde7fc402fd0a4bdf1ff49bc8 /configure.ac
parent963250abb99ab43b209281c2aa5398205492e555 (diff)
echo-cancel: orc-ify some bits for optimisation
This uses Orc to optimise an inner loop in the core NLMS function of the Adrian echo canceller.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5d69c924..45991281 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1321,6 +1321,9 @@ if test "x${with_fftw}" != "xno"; then
fi
AM_CONDITIONAL([HAVE_FFTW], [test "x$HAVE_FFTW" = "x1"])
+### ORC (optional) ###
+ORC_CHECK([0.4.9])
+
### Build and Install man pages ###
AC_ARG_ENABLE(manpages,
AS_HELP_STRING([--disable-manpages],[Disable building and installation of man pages]),
@@ -1573,6 +1576,11 @@ if test "x${HAVE_FFTW}" = "x1" ; then
ENABLE_FFTW=yes
fi
+ENABLE_ORC=no
+if test "x${HAVE_ORC}" = "xyes" ; then
+ ENABLE_ORC=yes
+fi
+
ENABLE_OPENSSL=no
if test "x${HAVE_OPENSSL}" = "x1" ; then
ENABLE_OPENSSL=yes
@@ -1626,6 +1634,7 @@ echo "
Enable gdbm: ${ENABLE_GDBM}
Enable simple database: ${ENABLE_SIMPLEDB}
Enable fftw: ${ENABLE_FFTW}
+ Enable orc: ${ENABLE_ORC}
System User: ${PA_SYSTEM_USER}
System Group: ${PA_SYSTEM_GROUP}