summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMaarten Bosmans <mkbosmans@gmail.com>2011-06-25 16:36:08 +0200
committerColin Guthrie <colin@mageia.org>2011-06-26 13:48:24 +0100
commitdf41b8c94872279c03563934aee4fe792091eda5 (patch)
treef832208ab3313eed541c49b63b583ff5988699a0 /configure.ac
parent08631831cbb7bcb8a8ec27f1682fb8ffea9df5ad (diff)
build-sys: Move some more defines from CFLAGS to config.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 6 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index e99ee6b5..8afb18c4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -427,6 +427,9 @@ AS_IF([test "$ac_cv_tls" == "__thread"],
AS_IF([test "x$os_is_win32" != "x1"],
[AX_PTHREAD])
+AS_IF([test "x$ax_pthread_ok" == "xyes"],
+ AC_DEFINE([_POSIX_PTHREAD_SEMANTICS], 1, [Needed on Solaris]))
+
#### Check for libs ####
@@ -580,9 +583,9 @@ AC_SUBST(LIBSPEEX_LIBS)
AC_MSG_CHECKING([whether we need libatomic_ops])
if test "x$need_libatomic_ops" = "xyes"; then
AC_MSG_RESULT([yes])
- AC_CHECK_HEADERS([atomic_ops.h], [], [
- AC_MSG_ERROR([*** libatomic-ops headers not found])
- ])
+ AC_CHECK_HEADERS([atomic_ops.h],
+ [CFLAGS="$CFLAGS -DAO_REQUIRE_CAS"],
+ [AC_MSG_ERROR([*** libatomic-ops headers not found])])
# Win32 does not need the lib and breaks horribly if we try to include it
AS_IF([test "x$os_is_win32" != "x1"], [LIBS="$LIBS -latomic_ops"])