summaryrefslogtreecommitdiffstats
path: root/schemas/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'schemas/Makefile.am')
-rw-r--r--schemas/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/schemas/Makefile.am b/schemas/Makefile.am
new file mode 100644
index 0000000..207c0a3
--- /dev/null
+++ b/schemas/Makefile.am
@@ -0,0 +1,16 @@
+SCHEMAS_FILE = service-discovery-applet.schemas
+
+EXTRA_DIST = $(SCHEMAS_FILE)
+
+schemasdir = $(GCONF_SCHEMA_FILE_DIR)
+schemas_DATA = $(SCHEMAS_FILE)
+
+install-schemas:
+ GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) gconftool-2 --makefile-install-rule $(SCHEMAS_FILE) 2>&1 > /dev/null
+ gconftool-2 --shutdown
+
+if GCONF_SCHEMAS_INSTALL
+install-data-local: install-schemas
+else
+install-data-local:
+endif