summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac30
1 files changed, 3 insertions, 27 deletions
diff --git a/configure.ac b/configure.ac
index 99bce11..9800a29 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,7 +20,7 @@
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
AC_PREREQ(2.57)
-AC_INIT([waproamd], [0.2], [mzjncebnzq (at) 0pointer (dot) de])
+AC_INIT([waproamd], [0.3], [mzjncebnzq (at) 0pointer (dot) de])
AC_CONFIG_SRCDIR([src/waproamd.c])
AC_CONFIG_HEADERS([config.h])
AM_INIT_AUTOMAKE([foreign -Wall])
@@ -37,7 +37,7 @@ if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -Wall"
fi
-if test -d /usr/local/stow ; then
+if type -p stow > /dev/null && test -d /usr/local/stow ; then
AC_MSG_NOTICE([*** Found /usr/local/stow: installing to /usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION} ***])
AC_PREFIX_DEFAULT([/usr/local/stow/${PACKAGE_NAME}-${PACKAGE_VERSION}])
fi
@@ -48,7 +48,6 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS([fcntl.h limits.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h unistd.h])
AC_CHECK_LIB([daemon], [daemon_fork],, [AC_MSG_ERROR([*** Sorry, you have to install libdaemon ***])])
-AC_CHECK_LIB([mcrypt], [mcrypt_module_open], [MCRYPT=1 AC_DEFINE(HAVE_MCRYPT, 1, [libmcrypt available])], [MCRYPT=0])
AC_C_CONST
AC_TYPE_MODE_T
@@ -101,15 +100,6 @@ fi
AM_CONDITIONAL([USE_XMLTOMAN], [test "x$xmltoman" = xyes])
-# Build aeswepd?
-AC_ARG_ENABLE(aeswepd,
- AC_HELP_STRING([--disable-aeswepd], [Disable building of aeswepd]),
-[case "${enableval}" in
- yes) aeswepd=yes ;;
- no) aeswepd=no ;;
- *) AC_MSG_ERROR([bad value ${enableval} for --disable-aeswepd]) ;;
-esac], [aeswepd=yes])
-
# Build waproamd?
AC_ARG_ENABLE(waproamd,
AC_HELP_STRING([--disable-waproamd], [Disable building of waproamd]),
@@ -119,19 +109,5 @@ AC_ARG_ENABLE(waproamd,
*) AC_MSG_ERROR([bad value ${enableval} for --disable-waproamd]) ;;
esac], [waproamd=yes])
-if test x$aeswepd = xno && test x$waproamd = xno ; then
- AC_MSG_ERROR([*** If you build neither aeswepd nor waproamd, nothing gets built ***])
-fi
-
-if test x$aeswepd = xyes && test x$MCRYPT != x1 ; then
- AC_MSG_ERROR([*** Sorry, you have to install libmcrypt or use --disable-aeswepd ***])
-fi
-
-AM_CONDITIONAL([BUILD_AESWEPD], [test "x$aeswepd" = xyes])
-AM_CONDITIONAL([BUILD_WAPROAMD], [test "x$waproamd" = xyes])
-
-AC_CONFIG_FILES([src/Makefile Makefile conf/Makefile doc/Makefile]) # man/Makefile doc/Makefile doc/README.html])
+AC_CONFIG_FILES([src/Makefile Makefile conf/Makefile doc/Makefile man/Makefile]) # doc/README.html])
AC_OUTPUT
-
-AC_MSG_NOTICE([*** aeswepd is built: $aeswepd ***])
-AC_MSG_NOTICE([*** waproamd is built: $waproamd ***])