summaryrefslogtreecommitdiffstats
path: root/conf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'conf/Makefile.am')
-rw-r--r--conf/Makefile.am18
1 files changed, 11 insertions, 7 deletions
diff --git a/conf/Makefile.am b/conf/Makefile.am
index e5b252f..2e6973c 100644
--- a/conf/Makefile.am
+++ b/conf/Makefile.am
@@ -16,27 +16,31 @@
# along with waproamd; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-SUBDIRS = scripts
-
if BUILD_WAPROAMD
-noinst_DATA = waproamd.init waproamd.conf
+noinst_DATA = waproamd.init waproamd.conf default
-EXTRA_DIST = waproamd.init.in waproamd.conf
+EXTRA_DIST = waproamd.init.in waproamd.conf default.in
-CLEANFILES = waproamd.init
+CLEANFILES = waproamd.init default
waproamd.init: waproamd.init.in Makefile
sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' $< > $@
chmod 755 $@
+default: default.in Makefile
+ sed -e 's,@sysconfdir\@,$(sysconfdir),g' -e 's,@sbindir\@,$(sbindir),g' $< > $@
+ chmod 755 $@
+
install-data-local: waproamd.init
- $(INSTALL) -D -m755 waproamd.init ${DESTDIR}/${sysconfdir}/init.d/waproamd
- $(INSTALL) -D -m644 $(srcdir)/waproamd.conf ${DESTDIR}/${sysconfdir}/waproamd/waproamd.conf
+ $(INSTALL) -b -D -m755 waproamd.init ${DESTDIR}/${sysconfdir}/init.d/waproamd
+ $(INSTALL) -b -D -m644 $(srcdir)/waproamd.conf ${DESTDIR}/${sysconfdir}/waproamd/waproamd.conf
mkdir -p ${DESTDIR}/${sysconfdir}/waproamd/keys
+ $(INSTALL) -D -m755 default ${DESTDIR}/${sysconfdir}/waproamd/scripts/default
uninstall-local:
rmdir ${DESTDIR}/${sysconfdir}/waproamd/keys
rm -f ${DESTDIR}/${sysconfdir}/init.d/waproamd ${DESTDIR}/${sysconfdir}/waproamd/waproamd.conf
+ rm -f ${DESTDIR}/${sysconfdir}/waproamd/scripts/default
endif