summaryrefslogtreecommitdiffstats
path: root/avahi-core/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-05-07 13:37:03 +0000
committerLennart Poettering <lennart@poettering.net>2005-05-07 13:37:03 +0000
commitc58379bde376cb2298fca14f83a86626f1b76f2f (patch)
tree976f81b6e3530f29187ce0c017da9c91e584af06 /avahi-core/Makefile.am
parente2c8b4dac0fefea406db0ec1a3b1c0861557601e (diff)
rename libavahi-core to avahi-core
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@57 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'avahi-core/Makefile.am')
-rw-r--r--avahi-core/Makefile.am88
1 files changed, 88 insertions, 0 deletions
diff --git a/avahi-core/Makefile.am b/avahi-core/Makefile.am
new file mode 100644
index 0000000..31268e8
--- /dev/null
+++ b/avahi-core/Makefile.am
@@ -0,0 +1,88 @@
+# $Id$
+#
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+AM_CFLAGS=-I$(top_srcdir) -D_GNU_SOURCE
+
+# GLIB 2.0
+AM_CFLAGS+=$(GLIB20_CFLAGS)
+AM_LDADD=$(GLIB20_LIBS)
+
+# This cool debug trap works on i386/gcc only
+AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
+
+lib_LTLIBRARIES = \
+ libavahi-core.la
+
+noinst_PROGRAMS = \
+ dns-test \
+ domain-test \
+ prioq-test \
+ strlst-test \
+ avahi-test
+
+libavahi_core_la_SOURCES = \
+ timeeventq.c timeeventq.h\
+ iface.c iface.h \
+ netlink.c netlink.h \
+ server.c server.h \
+ address.c address.h \
+ util.c util.h \
+ prioq.c prioq.h \
+ cache.c cache.h\
+ rr.c rr.h \
+ dns.c dns.h \
+ socket.c socket.h \
+ psched.c psched.h \
+ announce.c announce.h \
+ subscribe.c subscribe.h \
+ strlst.c strlst.h
+
+prioq_test_SOURCES = \
+ prioq-test.c \
+ prioq.c prioq.h
+prioq_test_CFLAGS = $(AM_CFLAGS)
+prioq_test_LDADD = $(AM_LDADD)
+
+strlst_test_SOURCES = \
+ strlst-test.c \
+ strlst.c strlst.h
+strlst_test_CFLAGS = $(AM_CFLAGS)
+strlst_test_LDADD = $(AM_LDADD)
+
+domain_test_SOURCES = \
+ domain-test.c \
+ util.c util.h
+domain_test_CFLAGS = $(AM_CFLAGS)
+domain_test_LDADD = $(AM_LDADD)
+
+dns_test_SOURCES = \
+ dns-test.c \
+ util.c util.h \
+ dns.c dns.h \
+ rr.c rr.h \
+ strlst.c strlst.h
+dns_test_CFLAGS = $(AM_CFLAGS)
+dns_test_LDADD = $(AM_LDADD)
+
+avahi_test_SOURCES = \
+ avahi-test.c
+avahi_test_CFLAGS = $(AM_CFLAGS)
+avahi_test_LDADD = $(AM_LDADD) libavahi-core.la
+
+