summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-06-07 14:18:20 +0000
committerTrent Lloyd <lathiat@bur.st>2005-06-07 14:18:20 +0000
commit1f2b8ac4ae09b15a0a6d1f7633f888654fd271dd (patch)
tree2dee241973ca232da09865cc3833fc7eb642b808 /configure.ac
parenta355be1c7ab89eb0ace82ce703b37ff30e081492 (diff)
* Patch by ross burton to allow make dist to pass (Closes: #3480)
* Move to doxygen in the default build, make --enable-doxygen=no to bypass, this also makes distcheck pass git-svn-id: file:///home/lennart/svn/public/avahi/trunk@106 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e17692d..b5492c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -89,6 +89,17 @@ if test "x$ENABLE_GTK" = "xyes"; then
fi
AM_CONDITIONAL(ENABLE_GTK, test "x$ENABLE_GTK" = "xyes")
+AC_ARG_ENABLE(doxygen,
+ AC_HELP_STRING([--enable-doxygen],[use doxygen to generate API docs (default=yes)]),
+ [case "${enableval}" in
+ yes) ENABLE_DOXYGEN=yes ;;
+ no) ENABLE_DOXYGEN=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-gtk) ;;
+ esac],
+ [ENABLE_DOXYGEN=yes]) dnl Default value
+
+AM_CONDITIONAL(ENABLE_DOXYGEN, test "x$ENABLE_DOXYGEN" = "xyes")
+
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
CFLAGS="$CFLAGS -pipe -W -Wall -pedantic"