summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-06-17 16:29:16 +0000
committerLennart Poettering <lennart@poettering.net>2005-06-17 16:29:16 +0000
commit6d4a9b90e98a98e5bb28289595558af745dbeed3 (patch)
tree6420b66767a4091302140b2f262d8f6b4fd00d87 /configure.ac
parent38cce0e6032f760ca98228907b9d7c6068269aeb (diff)
* check for expat in configure
* some premature command line parsing stuff git-svn-id: file:///home/lennart/svn/public/avahi/trunk@125 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a295d4..c9e2de5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,6 +112,15 @@ fi
AM_CONDITIONAL(ENABLE_DBUS, test "x$ENABLE_DBUS" = "xyes")
+AC_CHECK_LIB(expat, XML_ParserCreate, [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ], have_expat=false)
+
+if ! $have_expat ; then
+ AC_MSG_ERROR([*** libexpat not found ***])
+fi
+
+PKG_CHECK_MODULES(LIBDAEMON, [ libdaemon >= 0.5 ])
+AC_SUBST(LIBDAEMON_CFLAGS)
+AC_SUBST(LIBDAEMON_LIBS)
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then