summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-06-20 22:40:59 +0000
committerLennart Poettering <lennart@poettering.net>2005-06-20 22:40:59 +0000
commit724242be451a3c82e51dee0981b0f41f5a265e53 (patch)
tree6b6bc6f5bf01f1c0bc78db8b93f9909a80d2faac /configure.ac
parente26b546ee463cdbe2433367f6bcb9aec476fbee0 (diff)
* Apply another patch by Sebastien Estienne for installing glade interface files
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@132 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 11b7bc0..5d0cc76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,6 +84,18 @@ if test "x$ENABLE_GTK" = "xyes"; then
PKG_CHECK_MODULES(GLADE20, [ libglade-2.0 >= 2.4.0 ])
AC_SUBST(GLADE20_CFLAGS)
AC_SUBST(GLADE20_LIBS)
+
+ DATADIRNAME=share
+ if test "x${prefix}" = "xNONE"; then
+ AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/", [path where glade files will be installed])
+ interfacesdir="${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
+ AC_SUBST(interfacesdir)
+ else
+ AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/", [path where glade files will be installed])
+ interfacesdir="${prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
+ AC_SUBST(interfacesdir)
+ fi
+
fi
AM_CONDITIONAL(ENABLE_GTK, test "x$ENABLE_GTK" = "xyes")