summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-06-17 18:44:39 +0000
committerTrent Lloyd <lathiat@bur.st>2005-06-17 18:44:39 +0000
commit964e9764b0ea8a7580bbdecb40ac2b89f4d2858c (patch)
tree784537e596af3bf8a2a704f6b1749e5aecb12644 /configure.ac
parent6d4a9b90e98a98e5bb28289595558af745dbeed3 (diff)
* make the daemon build with dbus on both 0.23 and 0.30+, it doesn't yet work properly on 0.30 but it builds and runs
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@126 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c9e2de5..e0f35cf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -104,10 +104,16 @@ AC_ARG_ENABLE(dbus,
esac],
[ENABLE_DBUS=yes]) dnl Default value
+AC_DEFINE(ENABLE_DBUS, 1, [Whether to use DBUS or not])
+
if test "x$ENABLE_DBUS" = "xyes"; then
PKG_CHECK_MODULES(DBUS, [ dbus-glib-1 >= 0.23])
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
+
+ if pkg-config dbus-1 --atleast-version=0.30 ; then
+ AC_DEFINE(DBUS_USE_NEW_API, 1, [Whether to use the new API for DBUS 0.30])
+ fi
fi
AM_CONDITIONAL(ENABLE_DBUS, test "x$ENABLE_DBUS" = "xyes")