summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorTrent Lloyd <lathiat@bur.st>2005-08-23 11:59:02 +0000
committerTrent Lloyd <lathiat@bur.st>2005-08-23 11:59:02 +0000
commit9d125e3a3ae8a3bc4150756294226b3feb95799e (patch)
treee0d618cab16db9cb70193d0fd9c814a347e9906f /configure.ac
parent63c18f9eab7c30fe51c012d45f52947ce9e919d0 (diff)
* Re-enable use of gentoo initscripts
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@416 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 4 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index cc66f6d..993a4ea 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,10 +49,10 @@ AC_PROG_LIBTOOL
#
# Detecting the linux distro for specific things like initscripts.
#
-AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO],[Specify the Linux distribution to target: One of debian, archlinux or none]))
+AC_ARG_WITH(distro, AS_HELP_STRING([--with-distro=DISTRO],[Specify the Linux distribution to target: One of debian, gentoo, archlinux or none]))
if test "z$with_distro" = "z"; then
#AC_CHECK_FILE(/etc/SuSE-release,with_distro="suse")
- #AC_CHECK_FILE(/etc/gentoo-release,with_distro="gentoo")
+ AC_CHECK_FILE(/etc/gentoo-release,with_distro="gentoo")
AC_CHECK_FILE(/etc/arch-release,with_distro="archlinux")
AC_CHECK_FILE(/etc/debian_version,with_distro="debian")
fi
@@ -63,7 +63,7 @@ if test "z$with_distro" = "z"; then
exit 1
else
case $with_distro in
- debian|archlinux)
+ debian|gentoo|archlinux)
;;
*)
echo "Your distribution (${with_distro}) is not yet supported, init scripts and dbus configuration will not be installed! (patches welcome)"
@@ -349,6 +349,7 @@ avahi-discover-standalone/Makefile
avahi-client/Makefile
initscript/Makefile
initscript/debian/Makefile
+initscript/gentoo/Makefile
initscript/archlinux/Makefile
avahi-dnsconfd/Makefile
avahi-utils/Makefile