summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-07-06 15:46:31 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-07-06 15:46:31 +0000
commitaaa1c563f5f89f3f1e333a031cf71056fdc50e5e (patch)
tree0b45986a7f132b665f9a948c632d65995614e0b0 /configure.ac
parentaaf4c3e431d767ee628758abdc99f82b3af66b8f (diff)
* cleaned configure.ac
* fix Avahi runtime dir * use AM_CFLAGS instead of config.h.in to define paths (interfaces, socket, pid) git-svn-id: file:///home/lennart/svn/public/avahi/trunk@165 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 5 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d477743..e64fcde 100644
--- a/configure.ac
+++ b/configure.ac
@@ -90,13 +90,7 @@ if test "x$ENABLE_GTK" = "xyes"; then
AC_SUBST(GLADE20_CFLAGS)
AC_SUBST(GLADE20_LIBS)
- DATADIRNAME=share
- if test "x${prefix}" = "xNONE"; then
- interfacesdir="${ac_default_prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
- else
- interfacesdir="${prefix}/${DATADIRNAME}/${PACKAGE}/interfaces/"
- fi
- AC_DEFINE_UNQUOTED(INTERFACES_DIR, "${interfacesdir}", [path where glade files will be installed])
+ interfacesdir="${datadir}/${PACKAGE}/interfaces/"
AC_SUBST(interfacesdir)
fi
@@ -135,7 +129,6 @@ if test "x$ENABLE_DBUS" = "xyes"; then
DBUS_SYS_DIR="${sysconfdir}/dbus-1/system.d"
fi
AC_SUBST(DBUS_SYS_DIR)
- AC_DEFINE_UNQUOTED(DBUS_SYSTEMD_DIR, `eval echo $DBUS_SYS_DIR` , [Where system.d dir for DBUS is])
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
@@ -219,10 +212,10 @@ AC_DEFINE_UNQUOTED(AVAHI_GROUP,"$AVAHI_GROUP", [Group for Avahi])
#
# Avahi runtime dir
#
-avahi_runtime_dir=`eval echo ${localstatedir}/run/avahi`
-AC_DEFINE_UNQUOTED(AVAHI_RUNTIME_DIR, "${avahi_runtime_dir}", [path where pid and socket will be stored])
-AC_DEFINE_UNQUOTED(AVAHI_SOCKET, "${avahi_runtime_dir}/socket", [path for avahi socket])
-
+avahi_runtime_dir="${localstatedir}/run"
+avahi_socket="${avahi_runtime_dir}/avahi-daemon/socket"
+AC_SUBST(avahi_runtime_dir)
+AC_SUBST(avahi_socket)
AC_CONFIG_FILES([
Makefile