summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-08-07 10:25:26 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-08-07 10:25:26 +0000
commitc84527f98a43969ecd15a737fb000569feb4c9c0 (patch)
tree6d9b2bf2dc3f75e1fd08162f0c5983ccb4e2b58b /configure.ac
parentb4e1f08a735dfe56cdecb4337276a94d7da494a3 (diff)
* added a .desktop for avahi-discover
* added macro for checking python modules in common/python.m4 * check for python modules gtk and dbus git-svn-id: file:///home/lennart/svn/public/avahi/trunk@254 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d62397a..b9ebef3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,7 +253,24 @@ AC_SUBST(avahi_socket)
#
# Python stuff
#
-AM_PATH_PYTHON(2.4, [HAVE_PYTHON=yes], [HAVE_PYTHON=no])
+dnl AC_ARG_ENABLE(python,
+dnl AS_HELP_STRING(--disable-python, Disable scripts that depends on python),
+dnl [case "${enableval}" in
+dnl yes) use_python=yes ;;
+dnl no) use_python=no ;;
+dnl *) AC_MSG_ERROR([bad value ${enableval} for --disable-python]) ;;
+dnl esac],[use_python=yes])
+
+dnl HAVE_PYTHON=no
+dnl if test "x$use_python" = xyes ; then
+ AM_PATH_PYTHON(2.4, [HAVE_PYTHON=yes], [HAVE_PYTHON=no])
+
+ if test "x$HAVE_PYTHON" = xyes ; then
+ AM_CHECK_PYMOD(gtk,,,[AC_MSG_ERROR(could not find pygtk module)])
+ AM_CHECK_PYMOD(dbus,,,[AC_MSG_ERROR(could not find python dbus module)])
+ fi
+dnl fi
+
AM_CONDITIONAL(HAVE_PYTHON, [test "x$HAVE_PYTHON" = xyes ])
# ==========================================================================