summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastien Estienne <sebastien.estienne@gmail.com>2005-08-04 00:45:33 +0000
committerSebastien Estienne <sebastien.estienne@gmail.com>2005-08-04 00:45:33 +0000
commitcc0a4994f07b61952a77549fffa1711014f936be (patch)
tree928a036d76d898c2fed70edb4faecfa06408c210 /configure.ac
parent3ef5a5334ddfd9d48795e0b2670a7b052752d5e8 (diff)
* add some autoconf check for pygtk and gtk.glade
* moved autoconf/automake doxygen macro in common/ * remove autogenerated py-compile git-svn-id: file:///home/lennart/svn/public/avahi/trunk@224 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac55
1 files changed, 54 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 65d771f..4d12a0c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,6 +96,9 @@ if test "x$ENABLE_GTK" = "xyes"; then
fi
AM_CONDITIONAL(ENABLE_GTK, test "x$ENABLE_GTK" = "xyes")
+#
+# Doxygen
+#
DX_HTML_FEATURE(ON)
DX_CHM_FEATURE(OFF)
DX_CHI_FEATURE(OFF)
@@ -106,6 +109,9 @@ DX_PDF_FEATURE(OFF)
DX_PS_FEATURE(OFF)
DX_INIT_DOXYGEN(avahi, doxygen.cfg, doxygen)
+#
+# D-BUS
+#
AC_ARG_ENABLE(dbus,
AC_HELP_STRING([--enable-dbus],[use DBus (default=yes)]),
[case "${enableval}" in
@@ -135,12 +141,18 @@ fi
AM_CONDITIONAL(ENABLE_DBUS, test "x$ENABLE_DBUS" = "xyes")
+#
+# Expat
+#
AC_CHECK_LIB(expat, XML_ParserCreate, [ AC_CHECK_HEADERS(expat.h, have_expat=true, have_expat=false) ], have_expat=false)
if ! $have_expat ; then
AC_MSG_ERROR([*** libexpat not found ***])
fi
+#
+# LibDaemon
+#
PKG_CHECK_MODULES(LIBDAEMON, [ libdaemon >= 0.5 ])
AC_SUBST(LIBDAEMON_CFLAGS)
AC_SUBST(LIBDAEMON_LIBS)
@@ -216,9 +228,49 @@ avahi_socket="${avahi_runtime_dir}/avahi-daemon/socket"
AC_SUBST(avahi_runtime_dir)
AC_SUBST(avahi_socket)
-AM_PATH_PYTHON(2.4, [HAVE_PYTHON=yes], [HAVE_PYTHON=no])
+#
+# Python stuff
+#
+AC_SUBST(PYGTK_REQ, 2.6.0)
+
+AM_PATH_PYTHON(2.4)
+AM_PYTHON_CHECK_VERSION("$PYTHON", 2.4, [HAVE_PYTHON=yes], [HAVE_PYTHON=no])
AM_CONDITIONAL(HAVE_PYTHON, [test "x$HAVE_PYTHON" = xyes ])
+# check for pygtk
+PKG_CHECK_MODULES(PYGTK, pygtk-2.0 >= $PYGTK_REQ)
+PYGTK_DIR="`$PKG_CONFIG --variable=pyexecdir pygtk-2.0`"
+AC_SUBST(PYGTK_DIR)
+AC_MSG_NOTICE(Using pygtk installed in $PYGTK_DIR)
+PYGTK_VERSION="`$PKG_CONFIG --modversion pygtk-2.0`"
+if test "x$PYGTK_VERSION" = "x2.5.2"
+then
+ AC_MSG_ERROR([PyGTK 2.5.2 contains known bugs, please install other version])
+fi
+export PYTHONPATH=$PYGTK_DIR:$PYTHONPATH
+
+# check for gtk.glade
+AC_MSG_CHECKING(for gtk.glade)
+prog="
+import sys
+try:
+ import gtk.glade
+except RuntimeError:
+ sys.exit(0)
+except ImportError:
+ sys.exit(1)
+sys.exit(0)
+"
+
+if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
+then
+ AC_MSG_RESULT(found)
+else
+ AC_MSG_RESULT(not found)
+ AC_MSG_ERROR([You need to have python libglade bindings installed])
+fi
+
+dnl ==========================================================================
AC_CONFIG_FILES([
Makefile
avahi-core.pc
@@ -240,6 +292,7 @@ avahi-utils/avahi-publish-service
avahi-utils/avahi-publish-address
avahi-utils/avahi-discover
examples/Makefile
+common/Makefile
])
AC_OUTPUT