summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-05-06 16:37:33 +0000
committerLennart Poettering <lennart@poettering.net>2005-05-06 16:37:33 +0000
commiteca309458f9521a2e3276dc11a1792d5f2e227e4 (patch)
tree18d75f9654a9558ce96025c06baf171b9bc5c0ce /configure.ac
parent876fead3c8984cf985cca439bfb4c7d31c01ccc9 (diff)
add config.h inclusion to all *.c files
git-svn-id: file:///home/lennart/svn/public/avahi/trunk@55 941a03a8-eaeb-0310-b9a0-b1bbd8fe43fe
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 19 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ca0f216..40373df 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,10 +35,29 @@ fi
# Checks for programs.
AC_PROG_CC
+AC_PROG_CPP
+AC_PROG_INSTALL
+AC_PROG_LN_S
+AC_PROG_MAKE_SET
# libtool stuff
AC_PROG_LIBTOOL
+# Checks for header files.
+AC_HEADER_STDC
+AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h netinet/in.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_C_CONST
+AC_TYPE_SIZE_T
+AC_HEADER_TIME
+
+# Checks for library functions.
+AC_FUNC_MEMCMP
+AC_FUNC_SELECT_ARGTYPES
+AC_CHECK_FUNCS([gethostname memset select socket strchr strcspn strerror uname])
+
+# Check for GLIB 2.0
PKG_CHECK_MODULES(GLIB20, [ glib-2.0 >= 2.4.0 ])
AC_SUBST(GLIB20_CFLAGS)
AC_SUBST(GLIB20_LIBS)