summaryrefslogtreecommitdiffstats
path: root/gst/wavparse/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <bilboed@bilboed.com>2005-07-20 11:26:05 +0000
committerEdward Hervey <bilboed@bilboed.com>2005-07-20 11:26:05 +0000
commitd6a2d1aba196d9665eb706a09c4fd6e2e5a96c04 (patch)
tree125d9e17adda844fb403b7299c732403c4e1f797 /gst/wavparse/Makefile.am
parent961178077ee2b11f8ccfca69b97527da6ac2750d (diff)
Ported wavparse to 0.9 . Playing, seeking and state changes work.
Original commit message from CVS: * configure.ac: * gst/wavparse/gstwavparse.c: * gst/wavparse/gstwavparse.h: * gst/wavparse/Makefile.am: Ported wavparse to 0.9 . Playing, seeking and state changes work. Could need more loving on the headers though.
Diffstat (limited to 'gst/wavparse/Makefile.am')
-rw-r--r--gst/wavparse/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/gst/wavparse/Makefile.am b/gst/wavparse/Makefile.am
index 0f7df636..b2887ee4 100644
--- a/gst/wavparse/Makefile.am
+++ b/gst/wavparse/Makefile.am
@@ -2,8 +2,11 @@
plugin_LTLIBRARIES = libgstwavparse.la
libgstwavparse_la_SOURCES = gstwavparse.c
-libgstwavparse_la_CFLAGS = $(GST_CFLAGS)
-libgstwavparse_la_LIBADD =
-libgstwavparse_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstwavparse_la_CFLAGS = $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) \
+ -I$(top_srcdir)/gst-libs
+libgstwavparse_la_LIBADD = -lgstriff-0.9
+libgstwavparse_la_LDFLAGS = \
+ $(GST_PLUGIN_LDFLAGS) \
+ $(GST_PLUGINS_BASE_LIBS)
noinst_HEADERS = gstwavparse.h