summaryrefslogtreecommitdiffstats
path: root/ext/gdk_pixbuf/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/gdk_pixbuf/Makefile.am')
-rw-r--r--ext/gdk_pixbuf/Makefile.am12
1 files changed, 6 insertions, 6 deletions
diff --git a/ext/gdk_pixbuf/Makefile.am b/ext/gdk_pixbuf/Makefile.am
index b017fa56..82e0d3ef 100644
--- a/ext/gdk_pixbuf/Makefile.am
+++ b/ext/gdk_pixbuf/Makefile.am
@@ -8,7 +8,7 @@ libgstgdkpixbuf_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
if HAVE_GDK_LOADERS
-loaderdir = $(GDK_PIXBUF_LOADER_DIR)
+loaderdir = $(DESTDIR)$(GDK_PIXBUF_LOADER_DIR)
loader_LTLIBRARIES = gst_loader.la
gst_loader_la_CFLAGS = $(GST_CFLAGS) $(GTK_CFLAGS) -DGDK_PIXBUF_ENABLE_BACKEND
@@ -20,11 +20,11 @@ gst_loader_la_LIBADD = $(GTK_LIBS) $(GST_LIBS)
gst_loader_headers = gstgdkanimation.h
-#install-data-hook:
-# if test -z "$(DESTDIR)" ; then
-# $(mkinstalldirs) $(DESTDIR)$(GDK_PIXBUF_SYSCONFDIR)/gtk-2.0 ; \
-# $(QUERYLOADERS) > $(DESTDIR)$(GDK_PIXBUF_SYSCONFDIR)/gtk-2.0/gdk-pixbuf.loaders ; \
-# fi
+install-data-hook:
+ if test -z "$(DESTDIR)" ; then \
+ $(mkinstalldirs) $(DESTDIR)$(GDK_PIXBUF_SYSCONFDIR)/gtk-2.0 ; \
+ $(QUERYLOADERS) > $(DESTDIR)$(GDK_PIXBUF_SYSCONFDIR)/gtk-2.0/gdk-pixbuf.loaders ; \
+ fi
else
gst_loader_headers =