summaryrefslogtreecommitdiffstats
path: root/tests/examples/spectrum/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/examples/spectrum/Makefile.am')
-rw-r--r--tests/examples/spectrum/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/tests/examples/spectrum/Makefile.am b/tests/examples/spectrum/Makefile.am
index 0fd2ef17..a0a71629 100644
--- a/tests/examples/spectrum/Makefile.am
+++ b/tests/examples/spectrum/Makefile.am
@@ -1,5 +1,5 @@
if HAVE_GTK
-noinst_PROGRAMS = demo-osssrc demo-audiotest
+noinst_PROGRAMS = demo-osssrc demo-audiotest spectrum-example
endif
demo_osssrc_SOURCES = demo-osssrc.c
@@ -10,3 +10,7 @@ demo_audiotest_SOURCES = demo-audiotest.c
demo_audiotest_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GTK_CFLAGS)
demo_audiotest_LDFLAGS = $(GST_BASE_LIBS) $(GST_LIBS) $(GTK_LIBS)
+spectrum_example_SOURCES = spectrum-example.c
+spectrum_example_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(GTK_CFLAGS)
+spectrum_example_LDFLAGS = $(GST_BASE_LIBS) $(GST_LIBS) $(GTK_LIBS)
+