summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-07-19 21:22:12 +0200
committerLennart Poettering <lennart@poettering.net>2008-07-19 21:22:12 +0200
commit2572656862df480672d7f622a82737186894b0c1 (patch)
treeb0048a3724a463360ae4af424ada652533935a79 /Makefile.am
parent87f063d3446003907efbc74eaf1723a74fb6df1d (diff)
actually use strpool for the atasmart sources
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 8c22583..040029b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,7 @@
# License along with libatasmart. If not, If not, see
# <http://www.gnu.org/licenses/>.
-EXTRA_DIST = bootstrap.sh LGPL README atasmart.vapi
+EXTRA_DIST = bootstrap.sh LGPL README atasmart.vapi atasmart.c
SUBDIRS =
MAINTAINERCLEANFILES =
@@ -49,9 +49,15 @@ sktest_LDADD = \
libatasmart.la
libatasmart_la_SOURCES = \
- atasmart.c atasmart.h
+ atasmart.strpool.c atasmart.h
libatasmart_la_LDFLAGS = \
-version-info 0:0:0
strpool_SOURCES = \
strpool.c
+
+BUILT_SOURCES = \
+ atasmart.strpool.c
+
+atasmart.strpool.c: atasmart.c strpool
+ $(builddir)/strpool $< $@