summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2008-07-01 20:34:18 +0200
committerLennart Poettering <lennart@poettering.net>2008-07-01 20:34:18 +0200
commit25a3632fd96b60cf501fc1a7a96eef2e9103816e (patch)
tree4f5214e634d2a2fc19a8e40f7a4b0a99d9c648e9 /Makefile.am
parentfc7fd150835589a27a0447254a3b0ecb0612ee41 (diff)
autoconfization
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..b79f7fa
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,48 @@
+# This file is part of libatasmart.
+#
+# Copyright 2008 Lennart Poettering
+#
+# libatasmart is free software; you can redistribute it and/or modify
+# it under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation, either version 2.1 of the
+# License, or (at your option) any later version.
+#
+# libatasmart is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# Lesser General Public License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with libatasmart. If not, If not, see
+# <http://www.gnu.org/licenses/>.
+
+EXTRA_DIST = bootstrap.sh LGPL README
+SUBDIRS =
+
+MAINTAINERCLEANFILES =
+noinst_DATA =
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = libatasmart.pc
+
+bin_PROGRAMS = \
+ skdump \
+ sktest
+
+lib_LTLIBRARIES = \
+ libatasmart.la
+
+skdump_SOURCES = \
+ skdump.c
+skdump_LDADD = \
+ libatasmart.la
+
+sktest_SOURCE = \
+ sktest.c
+sktest_LDADD = \
+ libatasmart.la
+
+libatasmart_la_SOURCES = \
+ atasmart.c atasmart.h
+libatasmart_la_LDFLAGS = \
+ -version-info 0:0:0