summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2009-09-18 05:14:58 +0200
committerLennart Poettering <lennart@poettering.net>2009-09-18 05:16:42 +0200
commit60fe27c6e656227ad80c9b758bf811de8a5ea2f9 (patch)
tree39acec36d065757980e87911526de3f61ee3755f /Makefile.am
parent757f63057c810d545365d455c58e5df2575b8f77 (diff)
vala: install .vapi file
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 7 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 3f08277..3052f2f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,11 +16,12 @@
# License along with libatasmart. If not, If not, see
# <http://www.gnu.org/licenses/>.
+dist_doc_DATA = README
+
EXTRA_DIST = \
bootstrap.sh \
LGPL \
README \
- atasmart.vapi \
atasmart.c \
blob-examples/README \
blob-examples/FUJITSU_MHY2120BH--0084000D \
@@ -36,7 +37,8 @@ EXTRA_DIST = \
blob-examples/TOSHIBA_MK1651GSY--38IGT0G5T \
blob-examples/WDC_WD2500JB--00REA0-20.00K20 \
blob-examples/WDC_WD2500JS-75NCB3--10.02E04 \
- blob-examples/WDC_WD5000AAKS--00TMA0-12.01C01
+ blob-examples/WDC_WD5000AAKS--00TMA0-12.01C01 \
+ vala/atasmart.vapi
SUBDIRS =
@@ -48,6 +50,9 @@ noinst_DATA =
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libatasmart.pc
+vapidir = $(datadir)/vala/vapi
+vapi_DATA = vala/atasmart.vapi
+
include_HEADERS = \
atasmart.h