summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2009-10-27 22:53:50 +0100
committerLennart Poettering <lennart@poettering.net>2009-10-27 22:53:50 +0100
commiteb6d2d8737a72bb8466293a7649fea03f45c69d5 (patch)
tree0dc84d3d1bbeb54230ab0f7874faa4f7abd7daf8 /Makefile.am
parent4a6caeca4e8e9585a86470c11d2e75d5c1368d59 (diff)
Restrict the list of exported symbols to sk_.*
Use libtools' -export-symbols-regex to restrict the list of exported symbols so we not accidentally export symbols like init_smart
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 381e920..b5f9476 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -83,7 +83,8 @@ sktest_LDADD = \
libatasmart_la_SOURCES = \
atasmart.strpool.c atasmart.h
libatasmart_la_LDFLAGS = \
- -version-info $(LIBATASMART_VERSION_INFO)
+ -version-info $(LIBATASMART_VERSION_INFO) \
+ -export-symbols-regex '(^sk_.*)'
libatasmart_la_LIBADD = \
$(LIBUDEV_LIBS)
libatasmart_la_CFLAGS = \