summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2004-08-19 22:40:58 +0000
committerLennart Poettering <lennart@poettering.net>2004-08-19 22:40:58 +0000
commit5653891432df807a266ecb82f0c5a488711cba30 (patch)
treef4577e19234b4de87e5283f50ba7b398d08cb6aa /doc/Makefile.am
parent5853d14cab5661ebd6aa21d183f53668d8839b46 (diff)
add documentation
git-svn-id: file:///home/lennart/svn/public/paman/trunk@18 cdefa82f-4ce1-0310-97f5-ab6066f37c3c
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 0000000..577a2c5
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,36 @@
+# $Id$
+
+# This file is part of Polypaudio Manager.
+#
+# Polypaudio Manager is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# Polypaudio Manager is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with Polypaudio Manager; if not, write to the Free Software Foundation,
+# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
+
+noinst_DATA = README.html README
+EXTRA_DIST = $(noinst_DATA) style.css README.html.in
+
+MAINTAINERCLEANFILES = README README.html
+CLEANFILES =
+
+if USE_LYNX
+README: README.html
+ lynx --dump $^ | sed 's,file://localhost/.*/doc/README.html,README,' > $@
+
+CLEANFILES += README
+endif
+
+tidy: README.html
+ tidy -e < README.html
+
+.PHONY: tidy
+