summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2007-05-29 17:16:24 +0000
committerLennart Poettering <lennart@poettering.net>2007-05-29 17:16:24 +0000
commite4d63d0d8026446aec99ef8390554c5afd87cef4 (patch)
tree51609fbdece290c7e2d6f43da9b7336e6ea5314b /Makefile.am
parent5530d3295a3e65905346e98314f884a09a2be325 (diff)
add target "eolspace" to makefil to remove trailing newlines from all source files
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@1464 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 1b77187d..abc3d776 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -45,4 +45,7 @@ homepage: all dist doxygen
doxygen:
$(MAKE) -C doxygen doxygen
+eolspace:
+ find \( -name '*.c' -o -name '*.h' -o -name 'Makefile.am' \) -exec perl -i -pe 's/\s+\n$$/\1\n/;' \{\} \;
+
.PHONY: homepage distcleancheck doxygen