summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2005-09-16 00:02:10 +0000
committerLennart Poettering <lennart@poettering.net>2005-09-16 00:02:10 +0000
commit652e000f9e3b75fb705abf30c0dc447283a64191 (patch)
tree41ef842545fc68a0406fcc42d7ad0b1f70ea6c9b /configure.ac
parente0d0f1bb3e93690a18cfb8db96e12f5ae11b3320 (diff)
print a nice message when libltdl is missing
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@353 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 27cfeecd..12541345 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,14 @@ AC_LIBTOOL_DLOPEN
AC_PROG_LIBTOOL
AC_CONFIG_SUBDIRS(libltdl)
+if test "x$ac_cv_lib_ltdl_lt_dlinit" = "xno" ; then
+ AC_MSG_ERROR([[
+
+ *** Cannot find the libltdl development files.
+ *** Maybe you need to install the libltdl-dev package.
+ ]])
+fi
+
# Checks for header files.
AC_HEADER_STDC
AC_CHECK_HEADERS([arpa/inet.h fcntl.h inttypes.h limits.h malloc.h netdb.h netinet/in.h stddef.h stdint.h stdlib.h string.h sys/ioctl.h sys/socket.h sys/time.h unistd.h syslog.h])