summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2009-12-06 12:31:25 +0530
committerColin Guthrie <cguthrie@mandriva.org>2010-09-21 22:56:40 +0100
commit9729966ac35fee8d8a4638296b892475a9b8e88d (patch)
tree840f7659bd20e45a5e05ae1772ea879f66e747f7 /configure.ac
parent165cb87c3840ecfcfbe45846229304447be331b1 (diff)
Add a configure option to change 'udevrulesdir'
This patch serves two purposes: 1) Allows something other than the de-facto standard udev rules dir or /lib/udev/rules.d to be used (the udev build system allows you to customise this) 2) Allows a prefixed, non-root install (right now, the /lib/... path is hard-coded into the build system
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d15499c4..c2ff0666 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1374,6 +1374,13 @@ AC_ARG_WITH(
AC_SUBST(modlibexecdir)
+AC_ARG_WITH(
+ [udev-rules-dir],
+ AS_HELP_STRING([--with-udev-rules-dir],[Directory where to install udev rules to (defaults to /lib/udev/rules.d)]),
+ [udevrulesdir=$withval], [udevrulesdir="/lib/udev/rules.d"])
+
+AC_SUBST(udevrulesdir)
+
AC_ARG_ENABLE(
[force-preopen],
AS_HELP_STRING([--enable-force-preopen],[Preopen modules, even when dlopen() is supported.]),