summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorColin Guthrie <cguthrie@mandriva.org>2011-01-11 10:28:02 +0000
committerColin Guthrie <cguthrie@mandriva.org>2011-01-11 11:27:43 +0000
commitb3ff4f400f7f7149da579e16b9d979b7e2104caf (patch)
treedc2624cf240e11a9a5da1bf74b8057f08f441c63 /configure.ac
parent862bbee30949acf791e470c6c278b2fcb82bc79e (diff)
build-sys: Put in specific warnings when there is no udev or DBUS support
Users have often come to me when their build doesn't work and typically this is when they do not have dev headers for DBUS and udev installed when building. Put in some specific warnings about these optional, but critical, elements. This will likely display this message on platforms where they are not available, so patches welcome to hide them in a semi-intelligent way.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7b109d2d..5147a56d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1617,3 +1617,27 @@ echo "
Force preopen: ${FORCE_PREOPEN}
Preopened modules: ${PREOPEN_MODS}
"
+
+if test "${ENABLE_DBUS}" = "no" ; then
+ echo "
+===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====
+You do not have DBUS support enabled. It is strongly recommended
+that you enable DBUS support if you platform supports it.
+Many parts of PulseAudio use udev, from Console Kit interaction
+to the Device Reservation Protocol to speak to JACK, Bluetooth
+support and even a native control protocol for communicating and
+controling the PulseAudio daemon itself.
+===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====
+"
+fi
+
+if test "${ENABLE_UDEV}" = "no" ; then
+ echo "
+===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====
+You do not have udev support enabled. It is strongly recommended
+that you enable udev support if you platform supports it as it is
+the primary method used to detect hardware audio devices (on Linux)
+and is thus a critical part of PulseAudio on that platform.
+===== WARNING WARNING WARNING WARNING WARNING WARNING WARNING =====
+"
+fi