summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorArnaud Fontaine <arnau@debian.org>2011-03-29 22:56:28 +0159
committerColin Guthrie <colin@mageia.org>2011-05-07 17:01:28 +0100
commitb72fc9b4f158bafb66a7de28ce038986d96ce850 (patch)
treeddb709a3dc3ba2e35eeaddd156cf558c01edb503 /configure.ac
parent7fd0771522240445bd7d4d1df1e6bce79119c483 (diff)
x11: More XCB fixes.
Commit 65ef80b fixed building with xcb-util >= 0.3.8, but the reply is never checked (possible SIGSEGV if the reply is NULL) nor freed (memory leak at each call of the functions). Also, remove include and dependencies on xcb-atom, as it was only meaningful for xcb_atom_get() and STRING, and depend instead on xcb >= 1.6 for XCB_ATOM_STRING.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 299dd490..ed9bd172 100644
--- a/configure.ac
+++ b/configure.ac
@@ -547,7 +547,7 @@ AC_ARG_ENABLE([x11],
[x11=auto])
if test "x${x11}" != xno ; then
- PKG_CHECK_MODULES(X11, [ x11-xcb ice sm xtst xcb-atom ],
+ PKG_CHECK_MODULES(X11, [ x11-xcb xcb >= 1.6 ice sm xtst ],
HAVE_X11=1,
[
HAVE_X11=0