summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-10-07 19:30:11 +0200
committerDiego Elio 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-10-07 19:30:11 +0200
commitf55357cd0bcbc0a86f4ea9056584885897a8ec6c (patch)
treea056c69749e5aa2fdab4b11fcf53c11983d11a04 /configure.ac
parentb64b6bbf4c5eda8d4c80dd956987234d1378d055 (diff)
Add check for FFTW, and add option to disable it at build-time.
This way there will be a message at configure if FFTW is not found, and this gets in-line with the rest of the modules' dependencies.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fd10c83e..77ec8846 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1273,6 +1273,16 @@ AC_SUBST(OPENSSL_LIBS)
AC_SUBST(HAVE_OPENSSL)
AM_CONDITIONAL([HAVE_OPENSSL], [test "x$HAVE_OPENSSL" = x1])
+#### FFTW (optional) ####
+AC_ARG_WITH(
+ [fftw],
+ AS_HELP_STRING([--without-fftw], [Omit FFTW-using modules (equalizer)]))
+
+if test "x${with_fftw}" != "xno"; then
+ PKG_CHECK_MODULES([FFTW], [fftw3f], [HAVE_FFTW=1], [HAVE_FFTW=0])
+fi
+AM_CONDITIONAL([HAVE_FFTW], [test "x$HAVE_FFTW" = "x1"])
+
### Build and Install man pages ###
AC_ARG_ENABLE(manpages,
AS_HELP_STRING([--disable-manpages],[Disable building and installation of man pages]),