summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-01-11 14:13:28 +0000
committerPierre Ossman <ossman@cendio.se>2006-01-11 14:13:28 +0000
commit2623edcc4222884d57ce161e4ab0ba86feb8a2b8 (patch)
treec31feeafceaad5a2c33c40459d05bf401b08173d /configure.ac
parent70ac72ee7fa277705b8c3d8b0245d9a43740ef28 (diff)
Remove the old compiler flag test now that we have a new shiny one.
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@449 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 1 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 20d9b866..8a87928b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,15 +43,6 @@ AC_PROG_CC
AC_PROG_GCC_TRADITIONAL
AC_GNU_SOURCE
-# If using GCC specify some additional parameters
-if test "x$GCC" = "xyes" ; then
- CFLAGS="$CFLAGS -pipe -W -Wall -pedantic"
-
- AC_LANG_CONFTEST([int main() {}])
- $CC -c conftest.c -std=gnu9x -Wno-unused-parameter $CFLAGS > /dev/null 2> /dev/null && CFLAGS="$CFLAGS -std=gnu9x -Wno-unused-parameter"
- rm -f conftest.o
-fi
-
# M4
AC_PATH_PROG([M4], [m4 gm4], [no])
@@ -72,7 +63,7 @@ test_gcc_flag() {
# If using GCC specify some additional parameters
if test "x$GCC" = "xyes" ; then
- DESIRED_FLAGS="-Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline"
+ DESIRED_FLAGS="-Wall -W -Wextra -pedantic -pipe -Wformat -Wold-style-definition -Wdeclaration-after-statement -Wfloat-equal -Wmissing-declarations -Wmissing-prototypes -Wstrict-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wendif-labels -Wpointer-arith -Wbad-function-cast -Wcast-qual -Wcast-align -Wwrite-strings -Winline -Wno-unused-parameter"
if test "x$HAVE_NETLINK" = "xyes" ; then
# Test whether rtnetlink.h can be included when compiled with -std=c99