summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorPierre Ossman <ossman@cendio.se>2006-02-20 12:42:28 +0000
committerPierre Ossman <ossman@cendio.se>2006-02-20 12:42:28 +0000
commitd1bc972e6955601836c476093cb07ba961e51738 (patch)
tree2e92e620a0b585e9f50a9ad124a55a0d8ca4946f /configure.ac
parent0eed96d7649d63a24c2a251b143d26a46ab91742 (diff)
Detect support for Solaris (/dev/audio).
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@516 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4261903f..5ffea5ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -309,7 +309,10 @@ AM_CONDITIONAL([HAVE_ALSA], [test "x$HAVE_ALSA" = x1])
#### Solaris audio support (optional) ####
-AC_CHECK_HEADERS([sys/audio.h], [HAVE_SOLARIS=1], [HAVE_SOLARIS=0])
+AC_CHECK_HEADERS([sys/audio.h], [
+HAVE_SOLARIS=1
+AC_DEFINE([HAVE_SOLARIS], 1, [Have Solaris audio?])
+], [HAVE_SOLARIS=0])
AC_SUBST(HAVE_SOLARIS)
AM_CONDITIONAL([HAVE_SOLARIS], [test "x$HAVE_SOLARIS" = x1])