summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2006-07-16 17:38:45 +0000
committerLennart Poettering <lennart@poettering.net>2006-07-16 17:38:45 +0000
commit9ced7f62a7a453242eee9b56a0c5158753712ef4 (patch)
treee6fb1af6670d1a66fa07f118d45d65f701cb3326 /configure.ac
parent3b2843d5a8d50d6f9c3f5bedd63e3cc429c7ea13 (diff)
show summary after "configure" has run (closes: #22)
git-svn-id: file:///home/lennart/svn/public/pulseaudio/trunk@1094 fefdeb5f-60dc-0310-8127-8f9354f1896f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac77
1 files changed, 77 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a36ee5a0..10f511c6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -680,3 +680,80 @@ doxygen/doxygen.conf
src/pulse/version.h
])
AC_OUTPUT
+
+# ==========================================================================
+ENABLE_X11=no
+if test "x$HAVE_X11" = "x1" ; then
+ ENABLE_X11=yes
+fi
+
+ENABLE_OSS=no
+if test "x$HAVE_OSS" = "x1" ; then
+ ENABLE_OSS=yes
+fi
+
+ENABLE_ALSA=no
+if test "x$HAVE_ALSA" = "x1" ; then
+ ENABLE_ALSA=yes
+fi
+
+ENABLE_SOLARIS=no
+if test "x$HAVE_SOLARIS" = "x1" ; then
+ ENABLE_SOLARIS=yes
+fi
+
+ENABLE_GLIB20=no
+if test "x$HAVE_GLIB20" = "x1" ; then
+ ENABLE_GLIB20=yes
+fi
+
+ENABLE_GLIB12=no
+if test "x$HAVE_GLIB12" = "x1" ; then
+ ENABLE_GLIB12=yes
+fi
+
+ENABLE_AVAHI=no
+if test "x$HAVE_AVAHI" = "x1" ; then
+ ENABLE_AVAHI=yes
+fi
+
+ENABLE_JACK=no
+if test "x$HAVE_JACK" = "x1" ; then
+ ENABLE_JACK=yes
+fi
+
+ENABLE_LIBASYNCNS=no
+if test "x$HAVE_LIBASYNCNS" = "x1" ; then
+ ENABLE_LIBASYNCNS=yes
+fi
+
+ENABLE_LIRC=no
+if test "x$HAVE_LIRC" = "x1" ; then
+ ENABLE_LIRC=yes
+fi
+
+ENABLE_TCPWRAP=no
+if test "x${LIBWRAP_LIBS}" != x ; then
+ ENABLE_TCPWRAP=yes
+fi
+
+echo "
+ ---{ $PACKAGE_NAME $VERSION }---
+
+ prefix: ${prefix}
+ sysconfdir: ${sysconfdir}
+ localstatedir: ${localstatedir}
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ Have X11: ${ENABLE_X11}
+ Enable OSS: ${ENABLE_OSS}
+ Enable Alsa: ${ENABLE_ALSA}
+ Enable Solaris: ${ENABLE_SOLARIS}
+ Enable Glib 2.0: ${ENABLE_GLIB20}
+ Enable Glib 1.2: ${ENABLE_GLIB12}
+ Enable Avahi: ${ENABLE_AVAHI}
+ Enable Jack: ${ENABLE_JACK}
+ Enable Async DNS: ${ENABLE_LIBASYNCNS}
+ Enable LIRC: ${ENABLE_LIRC}
+ Enable TCP Wrappers: ${ENABLE_TCPWRAP}
+"