summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-20 00:55:39 +0100
committerDiego E. 'Flameeyes' Pettenò <flameeyes@gmail.com>2009-01-20 00:55:39 +0100
commitbd70e8053165bdee620356cdff02c3979d7138e7 (patch)
treed41200443166d7a5a9bc39ddfee0e93527a01aae /configure.ac
parent8c4e2be05b519c54cb51c161b7cd08bf9e46ab2b (diff)
Allow to opt-out from building tests.
Since the tests are only useful either if you're hacking at pulseaudio as a developer, or when running "make check", allow users to opt-out from their build. This for instance allows for Gentoo users not to build the tests when installing the ebuild with tests disabled, and also allow for skipping over eventually broken tests when trying to get the basic build going on a port.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8586dcdd..411a14d6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -101,6 +101,12 @@ for flag in $DESIRED_FLAGS ; do
CC_CHECK_CFLAGS([$flag], [CFLAGS="$CFLAGS $flag"])
done
+dnl Check whether to build tests by default (as compile-test) or not
+AC_ARG_ENABLE([default-build-tests],
+ AS_HELP_STRING([--disable-default-build-tests], [Build test programs only during make check]))
+
+AM_CONDITIONAL([BUILD_TESTS_DEFAULT], [test "x$enable_default_build_tests" = "xno"])
+
# Native atomic operation support
AC_ARG_ENABLE([atomic-arm-linux-helpers],
AS_HELP_STRING([--disable-atomic-arm-linux-helpers],[use inline asm or libatomic_ops instead]),